Search found 4 matches

by spoissant
Thu Sep 14, 2017 2:26 pm
Forum: Bullhorn APIs
Topic: Login request sometimes returns 400 - 'Bad Request' error
Replies: 1
Views: 3637

Re: Login request sometimes returns 400 - 'Bad Request' error

For anyone looking for an answer to this problem, I got in touch with a Bullhorn Tech Support and it appears this is a problem that can occur. For now we will be increasing the retries count (to 12) and adding a small delay between each retries. If I ever come up with or receive a better solution I'...
by spoissant
Wed Sep 06, 2017 2:31 pm
Forum: Bullhorn APIs
Topic: Login request sometimes returns 400 - 'Bad Request' error
Replies: 1
Views: 3637

Login request sometimes returns 400 - 'Bad Request' error

Hello, We have an integration with Bullhorn API for one of our client that essentially polls Bullhorn for events every minute or so. About every 5 minutes, we invoke oauth/token?grant_type=refresh_token&refresh_token={Settings.RefreshToken}&client_id={Settings.ClientId}&client_secret={Settings.Clien...
by spoissant
Wed Jun 28, 2017 10:18 am
Forum: Bullhorn APIs
Topic: 500 error trying to login after refreshing the access_token
Replies: 1
Views: 3440

Re: 500 error trying to login after refreshing the access_token

I think I MIGHT have found the problem.

I used to do my /login call with a POST. Switched it to a GET and it started working. Not too sure if I was just lucky that it worked with POST in the past or if they updated something on their end...
by spoissant
Wed Jun 28, 2017 9:57 am
Forum: Bullhorn APIs
Topic: 500 error trying to login after refreshing the access_token
Replies: 1
Views: 3440

500 error trying to login after refreshing the access_token

I`m a developer working on a BH integration for a client and I`m running into some issues login after refreshing my access_token. This is something that used to work perfectly a few days ago and now I keep running into 500 errors. Here`s my situation (this is all done in Postman but I`m also getting...