PublicJobPostingsXML return empty value

Have a question about Bullhorn's HTTP based APIs? You've found the right place.

API Update [posted on December 13, 2012]:

This version of the Bullhorn APIs should no longer be used.

All new work should be done using Bullhorn's REST or Web Services APIs. For more information please visit: http://developer.bullhorn.com/documentation

Bullhorn REST API provides a simpler and faster way for developers to build applications that interact with the Bullhorn platform and is used by Bullhorn Inc. to develop features of the Bullhorn ATS/CRM application.

Of the BullhornSTAFFING HTTP API interfaces listed below, our analysis shows that the following are most commonly used by developers:

Resume Parsing API
Published Job Data (XML)
The interface to these will continue to work as is because Bullhorn will replace the back end to use REST API. The URLs for these 2 specific APIs may change in the 2nd half of 2013; developers may require to update their applications to use the new URLs.

Moderators: StaffingSupport, s.emmons

Locked
wayne
User
Posts: 5
Joined: Wed Jul 09, 2008 12:41 am

PublicJobPostingsXML return empty value

Post by wayne » Wed Jul 09, 2008 12:49 am

Hi,

I am new to bullhorn API. I have tried to retrieve all the published jobs from the following API but to no avial.
http://www.bullhornstaffing.com/Bullhor ... ngsXML.cfm

My private label id is 2264.

There are currently 3 jobs being created and published at the back-end, however all i can see when use this API is <root></root>.

Please advise how can this be rectified.

Thanks!
Wayne

wayne
User
Posts: 5
Joined: Wed Jul 09, 2008 12:41 am

Post by wayne » Thu Jul 10, 2008 9:43 pm

can anyone tell me if this function is working??

Any setup i have not done to make it work?

c.richardson
Bullhorn Employee
Posts: 44
Joined: Wed Dec 31, 1969 8:00 pm

Post by c.richardson » Fri Jul 11, 2008 10:08 am

The API should be working.
Here is the test site for the PublicJobPostingsXML API:
http://www.bullhornstaffing.com/Bullhor ... MLTest.cfm
Try the API from there. If you are still not getting results back, make sure that the three jobs are published correctly: the 'isPublic' field must be set to 1 (probably 'Published - Approved' in the app) for the API to return them.

wayne
User
Posts: 5
Joined: Wed Jul 09, 2008 12:41 am

Post by wayne » Thu Jul 17, 2008 10:17 am

Hi Richardson, i have tested the API again using your method and the test site.
However there is no 'Published - Approved' option,so i selected 'Published - Submitted' instead. It still does not work, no jobs are being returned to the API.

Please help. Thanks.

c.richardson
Bullhorn Employee
Posts: 44
Joined: Wed Dec 31, 1969 8:00 pm

Post by c.richardson » Thu Jul 17, 2008 1:51 pm

The job needs to be set to 'Published - Approved' for the API to return it.
If this option isn't showing then this is something you may have to contact support about, to have them help you set it up.

wayne
User
Posts: 5
Joined: Wed Jul 09, 2008 12:41 am

Post by wayne » Fri Jul 18, 2008 4:05 am

Hi Richardson, may i have the email and contact number of bullhorn support. Or are you able to add the 'published - approved' for us.


My private label id is 2264.

Please advise. Thanks

cseibert
Bullhorn Employee
Posts: 392
Joined: Wed Dec 31, 1969 8:00 pm

Post by cseibert » Mon Jul 21, 2008 8:50 am


wayne
User
Posts: 5
Joined: Wed Jul 09, 2008 12:41 am

Post by wayne » Mon Jul 21, 2008 10:22 am

Thanks a lot. This has been resolved, 'published - approved' option was added and I can see jobs in the Published Job Data (XML).

But I have another problem, the field under Instructions>Skills/Experience called 'Business Sector', the value does not get published on the API. I could not find the field name and value on the xml result.

Can you tell me whether the value of this field 'Business Sector' can be published on the API as we need the value to be shown on the website?

Please assist. Appreciated.

cseibert
Bullhorn Employee
Posts: 392
Joined: Wed Dec 31, 1969 8:00 pm

Post by cseibert » Mon Jul 21, 2008 10:34 am

I called the API myself, and also checked the code. The business sector field is indeed not in the result set. There is no option to include it; it's just not supported by that API call right now. It's not available on another API, either.

There is no technical reason why it could not be added. I would recommend that you have your client start a feature request on Bullhorn Brainstorm, and escalate from there.

ernest.lopez
User
Posts: 10
Joined: Wed Dec 31, 1969 8:00 pm

Post by ernest.lopez » Fri Aug 08, 2008 11:58 am

PublicJobPostingsXMLTest.cfm not working for me. My id is 2333 I have several jobs set to published - approved. However when i use the api my results are:
<?xml version="1.0" encoding="UTF-8" standalone="yes" ?>
<root />

Locked