Unable to get access token with authorization code, invalid_client received

Forum for users and developers of Bullhorn's API service.

Moderators: StaffingSupport, s.emmons, BullhornSupport

Post Reply
adcooley
User
Posts: 2
Joined: Wed Sep 04, 2019 12:22 pm

Unable to get access token with authorization code, invalid_client received

Post by adcooley » Wed Sep 04, 2019 12:49 pm

We have a valid partner account with redirect uris set up (supposedly).

We're making this request in the browser first:

GET in browser bar: https://auth-west9.bullhornstaffing.com ... tion=Login

The response redirects to {REDIRECT_URI}?code=91%3Ac528ca2e-31e1-43f1-9d4c-0a9137e7537e&client_id={CLIENT_ID}

We're then taking that code and requesting an access token:

POST request: https://auth-west9.bullhornstaffing.com ... I_PASSWORD}

The response is:

{ "error" : "invalid_client", "error_description" : "Client authentication failed." }

Questions:
How do we know which data center to use?
Should we be using the ADMIN username and password or API username and password?

mholmemi
User
Posts: 24
Joined: Fri Feb 15, 2019 10:31 am

Re: Unable to get access token with authorization code, invalid_client received

Post by mholmemi » Wed Sep 11, 2019 9:20 am

Hi adcooley,

This is Mikaela from Bullhorn Support and I have taken ownership of this ticket.

This article tells you how to find your cluster: https://help.bullhorn.com/s/article/How ... -345053555, then you can use this article to find your data center and determine the specific API URL: http://bullhorn.github.io/Data-Center-URLs/

You should use the username and password of the API user. This article is really helpful for getting started: http://bullhorn.github.io/Getting-Started-with-REST/

I hope that helps!

Best,
Mikaela
Mikaela Holme-Miller | Tier II/Enterprise Support Analyst

Post Reply