Page 1 of 1

QueryException: Not all named parameters have been set

Posted: Wed May 21, 2014 4:35 am
by htphuong82
Hello there,

We are trying this: getBullhornResult(ApiEntityName.Candidate.value, "status like '%Active%' and isDeleted = 0")
But it does not work recently, it worked well before! (last Thursday maybe)
Do you guys change things on server side and we have to update it? Please advice.

I paste the exception in our console below:
org.hibernate.QueryException: Not all named parameters have been set: [_ userIdFilter] [SELECT a.id FROM com.bullhorn.entity.tearsheet.Tearsheet a WHERE (name LIKE '%AAA%') AND (a.isPrivate=0 OR a.owner.id=:_userIdFilter)]. Stacktrac e follows:
AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelopenServer
faultSubcode:
faultString: -99999: org.hibernate.QueryException: Not all named parameters hav e been set: [_userIdFilter] [SELECT a.id FROM com.bullhorn.entity.tearsheet.Tear sheet a WHERE (name LIKE '%AAA%') AND (a.isPrivate=0 OR a.owner.id=:_userIdFilte r)1
faultActor:
faultNode:
faultDetail: {http://jax-ws.dev.java.net/}exception:<message>-99999: org.hibernate.Qu eryException: Not all named parameters have been set:
Thanks,
Phuong

Re: QueryException: Not all named parameters have been set

Posted: Mon Jun 09, 2014 12:39 pm
by s.emmons
Hi Phuong,

Can you provide a copy of the request here?

Re: QueryException: Not all named parameters have been set

Posted: Thu Jun 26, 2014 5:14 am
by htphuong82
Sorry for late respond, our developer found a solution here [http://supportforums.bullhorn.com/viewt ... 71&p=58312]
But it seems someone already solved the problem, I don't have to use the cheat any more

Thanks