Not able to login

Forum for users and developers of Bullhorn's API service.

Moderators: StaffingSupport, s.emmons, BullhornSupport

Post Reply
egorgan
User
Posts: 5
Joined: Wed Jan 29, 2014 1:24 pm

Not able to login

Post by egorgan » Fri Mar 27, 2015 1:46 pm

Hi Guys,

We are experiencing similar issue as described here viewtopic.php?f=104&t=14369&p=59208#p59208.

Preconditions:
User is logged in into Bullhorn system (https://www.bullhornstaffing.com/)

After:
When trying to get auth_code using https://auth.bullhornstaffing.com/oauth the Unknown host error is received.
When using https://auth9.bullhornstaffing.com/oauth as suggested the auth_code was successfully received.

Access_token/refresh_token pair was also received without any problem

But when trying to login to the Rest API (https://rest.bullhornstaffing.com/rest- ... ess_token={xxxxxxxx})
the error is received saying invalid access token...

What are we doing wrong because we are following the procedures described here http://developer.bullhorn.com/articles/getting_started ?

In our case most of the time users will be logged in into Bullhorn system when accessing our application.
Our application is using REST API in background.

So the application has to go through the OAuth steps like obtaining code/oauth access and refresh tokens/bullhorn session in order to get access to the REST and start working it right ?!
if yes then there is an issue. Please see my previous comment and comments posted before as well.

In case users access our application anonymously the application or the REST API will force them to log in.

Any help is appreciated!

Thanks!

Post Reply