Assignee not added to Task

Forum for users and developers of Bullhorn's new REST API service.

Moderators: StaffingSupport, s.emmons, BullhornSupport

DrJones
User
Posts: 20
Joined: Sat Dec 12, 2015 1:20 pm

Assignee not added to Task

Postby DrJones » Mon Nov 27, 2017 10:35 am

I added a task via the API and then added an assignee to that task via the API using the to-many association and I get a successful response when making these requests. However, the task does not have the assigned user set if you look at the task in the UI. And because of this, the user does not get sent their reminder.

This is actually the same issue as this topic: viewtopic.php?f=104&t=24141&hilit=02604155. This topic states a ticket has been opened for the issue, which is great. But does anyone know when/if that is going to be fixed? And until then, is there some sort of workaround we can use to set the assignee? Actually, we don't even care about the assignee. We just want to make sure that the owner of the task gets sent the reminder. Is there a different way to accomplish that?

Thanks,

Kevin

xventola
User
Posts: 7
Joined: Wed Dec 06, 2017 1:38 pm

Re: Assignee not added to Task

Postby xventola » Wed Dec 06, 2017 2:05 pm

Hi DrJones,

This is Xander from Bullhorn Support.

Could you provide me with the corp ID and the Task ID that you added via REST and are not seeing the reference within the UI?

DrJones
User
Posts: 20
Joined: Sat Dec 12, 2015 1:20 pm

Re: Assignee not added to Task

Postby DrJones » Tue Dec 12, 2017 5:35 pm

TASK ID: 30
CORPORATE USER ID: 1

And here's the requests I'm making:

// Add task
PUT "REST_URL/entity/Task"

// Add assignee to task
PUT "REST_URL/entity/Task/NEW_TASK_ID/assignees/CORPORATE_USER_ID"

xventola
User
Posts: 7
Joined: Wed Dec 06, 2017 1:38 pm

Re: Assignee not added to Task

Postby xventola » Thu Dec 14, 2017 9:07 am

Hi DrJones,

Can you please also provide the corp ID so I can review in the specific database you are working in? Thanks!

DrJones
User
Posts: 20
Joined: Sat Dec 12, 2015 1:20 pm

Re: Assignee not added to Task

Postby DrJones » Thu Dec 14, 2017 3:27 pm

Corp ID: 10002

xventola
User
Posts: 7
Joined: Wed Dec 06, 2017 1:38 pm

Re: Assignee not added to Task

Postby xventola » Fri Dec 22, 2017 2:48 pm

Hi DrJones,

I believe the reason this call is failing is because the field name is actually "childTaskOwners" rather than "assignees". Please try again with this field name and let me know if you have any further issues. Thanks!

DrJones
User
Posts: 20
Joined: Sat Dec 12, 2015 1:20 pm

Re: Assignee not added to Task

Postby DrJones » Fri Dec 22, 2017 5:56 pm

You're right, that appears to be the right field. However, when I try to update it with this request:

PUT "REST_URL/entity/Task/NEW_TASK_ID/childTaskOwners/CORPORATE_USER_ID"

I get the following error:

{
"errorMessage" : "An internal error has occurred",
"errorMessageKey" : "errors.internalError"
}

However, I don't think I actually need to set this field for what I'm trying to accomplish. After some more testing, I've gotten closer to the root of the issue. I've created a new topic for this issue: viewtopic.php?f=104&t=24574.


Return to “REST API”

Who is online

Users browsing this forum: No registered users and 4 guests