ATTEMPT_TO_SET_TO_MANY on AssignedUsers for Job Order Creation

Forum for users and developers of Bullhorn's new REST API service.

Moderators: StaffingSupport, s.emmons, BullhornSupport

Post Reply
teberle
User
Posts: 3
Joined: Thu Sep 14, 2017 4:52 pm

ATTEMPT_TO_SET_TO_MANY on AssignedUsers for Job Order Creation

Post by teberle » Tue Dec 11, 2018 1:01 pm

I am attempting to set the assignedUsers via the REST Api but get the following error when I either do a 'PUT' or a 'POST'

"changedEntityType": "JobOrder",
"changedEntityId": 12546,
"changeType": "INSERT",
"messages": [
{
"propertyName": "assignedUsers",
"severity": "WARNING",
"type": "ATTEMPT_TO_SET_TO_MANY"
}
],

{
"changedEntityType": "JobOrder",
"changedEntityId": 12545,
"changeType": "UPDATE",
"messages": [
{
"propertyName": "assignedUsers",
"severity": "WARNING",
"type": "ATTEMPT_TO_SET_TO_MANY"
}
],
"data": {
"assignedUsers": {
"id": 16
}
}
}

Can you provide information on the correct way to set the assignedUsers in the JobOrder Creation?

DanJSupport
User
Posts: 46
Joined: Mon Aug 15, 2016 9:57 am

Re: ATTEMPT_TO_SET_TO_MANY on AssignedUsers for Job Order Creation

Post by DanJSupport » Fri Dec 21, 2018 11:18 am

Hi Teberle,

The To-Many association fields need to be created after the job is created with a PUT call like this:

Code: Select all

https://rest34.bullhornstaffing.com/rest-services/{corp_token}/entity/JobOrder/{jobID}/assignedUsers/{userID}
See our documentation on PUT Entity: http://bullhorn.github.io/rest-api-docs ... put-entity
Dan Johnson
Tier 2 / Enterprise Support
Bullhorn Support US: 617-478-9126
Bullhorn Support UK: 44 800 032 2848
Bullhorn Support Australia: 61 28 073 5089
Bullhorn Support International: 617-478-9131

Post Reply