Page 1 of 1

addFile throwing error

Posted: Wed May 24, 2017 9:15 am
by websolutions
Hello,

I'm getting the following error when calling the addFile web service method:

"org.apache.poi.poifs.filesystem.POIFSFileSystem.getRoot()Lorg/apache/poi/poifs/filesystem/DirectoryEntry;"

stack trace:

Code: Select all

System.Object[] ReadResponse(System.Web.Services.Protocols.SoapClientMessage, System.Net.WebResponse, System.IO.Stream, Boolean)
System.Object[] Invoke(System.String, System.Object[])
BullhornStaffingAPI.apiAddFileResult addFile(System.String, System.String, System.Object, BullhornStaffingAPI.fileMeta, Byte[])
Void Page_Load(System.Object, System.EventArgs)
It seems to be only happening on one specific document (file name "David_Hess.doc"), but the error message returned is not exactly helpful.

I'm using the SOAP API Version 2.6

Let me know if you need any further information.

Thanks,
-Tom

Re: addFile throwing error

Posted: Tue May 30, 2017 9:48 am
by websolutions
Just wanted to follow up that I'm now receiving this error on other files. So any help would be greatly appreciated.

Thanks.

Re: addFile throwing error

Posted: Fri Jun 02, 2017 11:44 am
by websolutions
I was able to resolve the issue temporarily by opening the .doc file and saving as a .docx file, and then tried re-uploading and it worked successfully.

While this is not an ideal or permanent solution, it works for now.