Invalid response returned by find operation

Forum for users and developers of Bullhorn's Webservices API suite

Moderators: StaffingSupport, s.emmons, BullhornSupport

ksprocom
User
Posts: 23
Joined: Wed Mar 17, 2010 2:43 pm

Invalid response returned by find operation

Post by ksprocom » Mon May 31, 2010 4:27 pm

Hi,

I am trying to retrieve a Candidate record, ID 1626, with the WS API (https://api.bullhornstaffing.com/webservices-1.1/) using the find() operation. The API call unfortunately causes the following error:
Error in deserializing body of reply message for operation 'find'.
There is an error in XML document (7, 561).
The byte 0x0B is not valid at this location.
It appears that the SOAP response message is incorrectly serialized. I can successfully retrieve other Candidate records, just not this one, so it seems to me that it is a data problem.

I would appreciate help with this issue ASAP. Our corporation ID is 2467.

Thanks in advance.

apsmith
Site Admin
Posts: 2051
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by apsmith » Wed Jun 02, 2010 8:36 am

ks,

It looked as though there was some bad data in the resume field, I have cleansed this data, can you retry the action?
Andrew Smith
Director, Technical Operations
Developer Forum Admin

ksprocom
User
Posts: 23
Joined: Wed Mar 17, 2010 2:43 pm

Re: Invalid response returned by find operation

Post by ksprocom » Thu Jun 03, 2010 11:29 am

Hi Andrew,

That did the trick, thanks. I have since performed a full scan of all Candidate records with the API, and it has revealed 101 other records with the same issue. Can I pass this list of Candidates onto you to fix, or should they go to our main Bullhorn contact?

apsmith
Site Admin
Posts: 2051
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by apsmith » Thu Jun 03, 2010 2:01 pm

KSprocom,

Please send this through to Bullhorn Support, they are your best resource for getting it resolved.
Andrew Smith
Director, Technical Operations
Developer Forum Admin

steve.major
User
Posts: 49
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by steve.major » Tue Jun 29, 2010 12:04 pm

I am getting this same error message on a great deal of candidates. I do not think it is malformed resume text.
If you look at Candidate 123619 you'll see that his resume is fairly lightweight and has no offending characters in it.
Have you found anything else about this error since this was first posted that will help toward resolution?

Thanks,
Steve

apsmith
Site Admin
Posts: 2051
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by apsmith » Tue Jun 29, 2010 1:41 pm

Steve,

There was a bad (single) character in this resume. I have removed it, can you retry?
Andrew Smith
Director, Technical Operations
Developer Forum Admin

steve.major
User
Posts: 49
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by steve.major » Tue Jun 29, 2010 1:53 pm

Thank you for removing the bad character. I am still getting the same error:
"Error in deserializing body of reply message for operation 'find'."

Please advise...

apsmith
Site Admin
Posts: 2051
Joined: Wed Dec 31, 1969 8:00 pm

Re: Invalid response returned by find operation

Post by apsmith » Tue Jun 29, 2010 2:13 pm

Steve,

I just ran a find operation and did not have any errors, can you retry? Below is the XML request that I tried:

Code: Select all

<soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:apis="http://apiservice.bullhorn.com/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:xs="http://www.w3.org/2001/XMLSchema">
   <soapenv:Header/>
   <soapenv:Body>
      <apis:find>
         <session>
<client>---XXXXX----</client>

            <corporationId>XXXX</corporationId>

            <userId>XXXXX</userId>

         </session>
          <entityName>Candidate</entityName>
         <id xsi:type="xs:int">123619</id>
      </apis:find>
   </soapenv:Body>
</soapenv:Envelope>
Andrew Smith
Director, Technical Operations
Developer Forum Admin

sourov.chatterjee
User
Posts: 20
Joined: Thu Sep 02, 2010 11:21 am

Re: Invalid response returned by find operation

Post by sourov.chatterjee » Wed Apr 27, 2011 1:10 pm

This issue seems to be open after Steve's initial posting.

error in deserilizing body of reply message for operation 'find'
there is an error in XML document (11, 1295)


We are trying to update customText1 for candidate record. It failes randomly. Is it due to error in resume text?

Please help!!

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: Invalid response returned by find operation

Post by jdonnelly » Wed Apr 27, 2011 1:41 pm

Hello Sourov,

It is quite possible that you are seeing the same issue due to the contents of a resume for a candidate, but we will need to take a closer look in order to be sure. Can you provide your corporation ID and the IDs of the candidates that you are having issues with?

Thank you,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

sourov.chatterjee
User
Posts: 20
Joined: Thu Sep 02, 2010 11:21 am

Re: Invalid response returned by find operation

Post by sourov.chatterjee » Wed Apr 27, 2011 3:12 pm

In am not sure abt corp ID - name is Sapphire tech.
candidate ID - 2091017

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: Invalid response returned by find operation

Post by jdonnelly » Wed Apr 27, 2011 3:59 pm

Hello Sourov,

That candidate's data looks fine for your corporation and I was not able to reproduce the issue when using your credentials to perform a find for that candidate.

Can you confirm that the operation that you are having trouble with is the find operation and that you provided the correct candidate id? If this information is correct, can you please provide the SOAP envelope for the request that is failing? If the data provided is correct, then it is also possible that the error that you provided is coming from your code and that your code is not handling something in the data quite right (googling the error message shows results for c# errors with that text, and there is no c# code on our side).

Please let me know if anything is not clear or if you have any questions.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

sourov.chatterjee
User
Posts: 20
Joined: Thu Sep 02, 2010 11:21 am

Re: Invalid response returned by find operation

Post by sourov.chatterjee » Thu Apr 28, 2011 9:40 am

can you try #166366 ? Thanks

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: Invalid response returned by find operation

Post by jdonnelly » Thu Apr 28, 2011 12:13 pm

Hello Sourov,

I was unable to reproduce the issue with that candidate using your credentials with soapUI, a powershell client, and a php client. Can you confirm that you are seeing the issue with Candidate 166366? If so, it sounds like the issue might be in your code somewhere. Can you try to debug further on your side or, try to isolate the code that is making the call and processing the response and provide it so that I can debug it?

Please let me know if anything is not clear or if you have any questions.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

sourov.chatterjee
User
Posts: 20
Joined: Thu Sep 02, 2010 11:21 am

Re: Invalid response returned by find operation

Post by sourov.chatterjee » Fri Apr 29, 2011 11:13 am

Jon, thanks for helping us.
We have updated 50000 records in the last couple of weeks using the same code that we have here. It fails on few including #166366 , it is failing consistently. I believe there is no code issues on our side, its a data issue. When I debug, the error originates from the api.bullhornstaffing.com library and I get the de-Serialize error.

Post Reply