WebServices 2 parseResume fails with host parameter is null

Forum for users and developers of Bullhorn's Webservices API suite

Moderators: StaffingSupport, s.emmons, BullhornSupport

Post Reply
nvanesch
User
Posts: 8
Joined: Wed Apr 20, 2011 10:57 am

WebServices 2 parseResume fails with host parameter is null

Post by nvanesch » Fri May 06, 2011 8:27 am

Testing the parseResume method on the bullhorn stage server for Logic Melon Multiple Job Posting and Applicant Tracking and the method returns the following in diagnostics
Exception=java.lang.IllegalArgumentException: host parameter is null

Code: Select all

<?xml version="1.0" ?><S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"><S:Body><ns2:parseResumeResponse xmlns:ns2="http://apiservice.bullhorn.com/"><return><session>...</session><diagnostics>Exception=java.lang.IllegalArgumentException: host parameter is null
</diagnostics><success>false</success></return></ns2:parseResumeResponse></S:Body></S:Envelope>
Is this a problem on the server or something with what we are sending.

The only parameters are a session string and byte[] data for the cv

apsmith
Site Admin
Posts: 2051
Joined: Wed Dec 31, 1969 8:00 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by apsmith » Fri May 06, 2011 10:00 am

nvanesch,

Can you post the XML that you are sending, with the version of the WSDL, so that we can test? (excluding security credentials)
Andrew Smith
Director, Technical Operations
Developer Forum Admin

nvanesch
User
Posts: 8
Joined: Wed Apr 20, 2011 10:57 am

Re: WebServices 2 parseResume fails with host parameter is null

Post by nvanesch » Mon May 09, 2011 5:19 am

Version 2 of the api with the WSDL collected on Friday. cv truncated due to character limitation but I do not believe cv specific

Code: Select all

POST https://api-staging.bullhorn.com/webservices-2.0/ HTTP/1.1
Content-Type: text/xml; charset=utf-8
VsDebuggerCausalityData: uIDPo8xCorqzehhOruXH3Mv/GfEAAAAA6YPDzsbmvUC+4wueDXn3xcKzs2KI6eJKvGdBx7UgQVoACQAA
SOAPAction: ""
Host: api-staging.bullhorn.com
Content-Length: 68653
Expect: 100-continue

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/"><s:Body xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><parseResume xmlns="http://apiservice.bullhorn.com/"><session xmlns="">rO0ABX...</session><base64ChunkedResume xmlns="">0M8R4KGx...</base64ChunkedResume></parseResume></s:Body></s:Envelope>
response

Code: Select all

HTTP/1.1 200 OK
Date: Mon, 09 May 2011 09:16:34 GMT
X-Powered-By: Servlet 2.4; JBoss-4.2.1.GA (build: SVNTag=JBoss_4_2_1_GA date=200707131605)/Tomcat-5.5
Content-Type: text/xml;charset=utf-8
Content-Length: 1096

<?xml version="1.0" ?><S:Envelope xmlns:S="http://schemas.xmlsoap.org/soap/envelope/"><S:Body><ns2:parseResumeResponse xmlns:ns2="http://apiservice.bullhorn.com/"><return><session>rO0...</session><diagnostics>Exception=java.lang.IllegalArgumentException: host parameter is null
</diagnostics><success>false</success></return></ns2:parseResumeResponse></S:Body></S:Envelope>

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Mon May 09, 2011 10:40 am

Hello nvanesch,

This appears to be a bug, I have esacalated this issue. I will update this thread when I have more information.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

nvanesch
User
Posts: 8
Joined: Wed Apr 20, 2011 10:57 am

Re: WebServices 2 parseResume fails with host parameter is null

Post by nvanesch » Wed May 11, 2011 8:05 am

Any reply on this.

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Thu May 12, 2011 9:45 am

Hello nvanesch,

Sorry for the inconvenience, but no news yet. I will reply to this thread when I have more information.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

nvanesch
User
Posts: 8
Joined: Wed Apr 20, 2011 10:57 am

Re: WebServices 2 parseResume fails with host parameter is null

Post by nvanesch » Mon May 16, 2011 7:35 am

Hi Jon

Any news on this yet?

Thanks
Nick van esch
http://www.logicmelon.co.za

cdmorrow
User
Posts: 17
Joined: Tue May 03, 2011 9:22 am

Re: WebServices 2 parseResume fails with host parameter is null

Post by cdmorrow » Mon May 16, 2011 4:48 pm

Same here. What is ETA for bug fix?

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Mon May 23, 2011 9:26 am

Hello,

There is currently no eta for the fix. I will update the thread when I have more information.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Thu Jun 09, 2011 10:21 am

Hello,

This issue is now resolved for API 2.0. Let me know if you have any questions.

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

traejen
User
Posts: 3
Joined: Wed Aug 03, 2011 2:49 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by traejen » Wed Aug 03, 2011 2:55 pm

This issue seems to have regressed, or is recurring.

I get the following response when sending a file [any file]:

Code: Select all

stdClass Object
(
    [session] => rO0ABXVyAAJbQqzzF/gGCFTgAgAAeHAAAAIAkX5oaIxxLwRfOHS3barhLcQ4dVbAymls8iTqLe35
K9wSuhYREBZvpuDlybvicoYUYpSwHhqknNpcPohVKcnAvcOgYNeVGDqnrsshrd/ma+9IVI/zxdkv
Iif6/IjkET8T4oYUe9LnO7u9wTS9tDi9rnlYVXugwuKnvyfr+aVBmj1x0JIJXfU0uJ/1N2oLUVse
aX0mdIYokVWMWml+tQJLiHNx3JOoNgOvvVfopBYmMscxO+4Y96JZb1JGKTDvb1MGjRYyfttyOUXa
bV/UHuQADlP4ipLcZWPJmjNlu3YWK2wA6mQGIdVF5vi/c10cb+jO4cRhKpoYgScBMLpDWMCSLvHo
tt1gzQiJvSrJkmJemDu3uDR0k7m7pyJsZtiTTG/Jaepy1eer8AafZPpcjBGVHi8gkQqBP+922gB3
znpbes+DlW8fpEUffe/cc29Gkbjosan0TEkWRCv1E7ktHasyXFvqDvq820bSV0/QIN8tx3liGVSs
gq2nCYjhlmDkzfIB99xHYEQdkT31MU7BwnxPmAYIKDS72r9xp0NCb/07aqsU2bHprAsf2cnVDofd
sp5RrYHx+4oCetNybiHeq5GkuTuQo61q9TsWIb5PTAeSfAB/6258Hl6aF3+hZs++l01oY+92Jxg+
HEQD3HxCVyw/S2+bfzo6GIl6zg1n+9JA8RY=
    [diagnostics] => Exception=java.lang.IllegalArgumentException: host parameter is null

    [success] => 
)

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Mon Aug 08, 2011 11:37 am

Hello Traejen,

Can you provide your corpid and the wsdl url that you are using?

Thanks!
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

traejen
User
Posts: 3
Joined: Wed Aug 03, 2011 2:49 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by traejen » Mon Aug 08, 2011 1:29 pm

I think the corporation ID is 3509, but I could be mistaken. WSDL URL: http://api-staging.bullhorn.com/webservices-2.0/?wsdl

jdonnelly
User
Posts: 192
Joined: Wed Feb 09, 2011 4:57 pm

Re: WebServices 2 parseResume fails with host parameter is null

Post by jdonnelly » Mon Aug 08, 2011 1:42 pm

Hello Traejen,

The url that you are using is for the staging environment - can you have someone at your company follow up with your implementation representative in order to investigate this issue?

Thanks,
Jon Donnelly
Technical Support Engineer
Developer Forum Admin
B U L L H O R N
support@bullhorn.com

Post Reply