Rest API - Initial auth request didn't return Auth_code

Forum for users and developers of Bullhorn's API service.

Moderators: StaffingSupport, s.emmons, BullhornSupport

Post Reply
bharathbhdisys
User
Posts: 3
Joined: Mon Jun 29, 2020 7:50 am

Rest API - Initial auth request didn't return Auth_code

Post by bharathbhdisys »

Hi Team,

I have updated the require detail in the below URL and sent request but the response is received in HTML format which doesn't contain the Auth_Code.

https://auth.bullhornstaffing.com/oauth ... ={optional redirect_uri}&state={recommended state value}

As a second option, i have tried with out action=login parm, and manually logged into the bulhorn through browser and able to get the Auth_code.

could you please help me to understand why the first option is not working? and should i do any changes in the request?

Thanks & Regards,
Bharath Kumar B

bbagwell
User
Posts: 16
Joined: Wed Feb 26, 2020 12:17 pm

Re: Rest API - Initial auth request didn't return Auth_code

Post by bbagwell »

Hello. Please see http://bullhorn.github.io/Getting-Started-with-REST/

Use a refresh token to get a new access token
To obtain an access token with a refresh token, make a POST request with the following URL, substituting your actual values for the placeholders in the query parameters:

Code: Select all

https://auth.bullhornstaffing.com/oauth/token?grant_type=refresh_token&refresh_token={refresh_token}&client_id={client_id}&client_secret={client_secret}

Post Reply